虫虫教学

 找回密码
 立即注册

QQ登录

12
返回列表 发新帖回复
楼主: 紫雪

手游封包外挂第六课 : 完善封包发送器的编写

[复制链接]
发表于 2018-8-24 13:50:11 | 显示全部楼层
拿走了  谢谢

12

主题

287

帖子

611

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
878
发表于 2018-10-22 21:19:11 来自手机 | 显示全部楼层
非常感谢,感谢分享!

1

主题

29

帖子

43

学币

初级会员

Rank: 2Rank: 2

积分
129
发表于 2019-8-2 14:34:21 | 显示全部楼层
有虫虫的地方,就有我

3

主题

153

帖子

13

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
594
发表于 2019-8-21 14:10:07 | 显示全部楼层
辛苦了,谢谢
发表于 2019-8-28 13:19:14 | 显示全部楼层
这课的源码如下:


.版本 2
.支持库 spec


.程序集 窗口程序集_窗口1


.子程序 _窗口1_创建完毕






.子程序 发送封包程序
.局部变量 游戏端口, 整数型
.局部变量 封包内容, 字节集
.局部变量 封包指针, 整数型
.局部变量 封包大小, 整数型
.局部变量 i, 整数型


.计次循环首 (到整数 (编辑框2_发送次数.内容), i)
    游戏端口 = 到整数 (编辑框4_游戏端口.内容)


    封包内容 = 转换_字节集还原 (删全部空 (编辑框1_发送封包.内容), )


    封包指针 = 指针_取字节集地址 (封包内容)


    封包大小 = 取字节集长度 (封包内容)


    延迟 (到整数 (编辑框3_发送间隔.内容))


    编辑框5_己发次数.内容 = 到文本 (i)


    封包拦截.发送send (游戏端口, 封包指针, 封包大小, 0)


.计次循环尾 ()




.子程序 _按钮1_被单击


发送封包程序 ()

展开

QQ|小黑屋|手机版|虫虫教学 ( 赣ICP备18011882号 )

GMT+8, 2019-12-7 02:33 , Processed in 0.134615 second(s), 36 queries .

bestcclm. com X3.4

© 2018 Bestcclm.

快速回复 返回顶部 返回列表