虫虫教学

 找回密码
 立即注册

QQ登录

广告位招租
查看: 4211|回复: 16

手游封包外挂第六课 : 完善封包发送器的编写

[复制链接]
发表于 2017-10-8 10:55:39 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
手游封包外挂第六课 : 完善封包发送器的编写


           因视频上传网站审核不过关,所以想学习的同学只能到百度网盘上观看。


            视频下载地址  https://pan.baidu.com/s/1PYiLp52ixUd7FUWr5aoo3A








发表于 2019-8-28 13:19:14 | 显示全部楼层
这课的源码如下:


.版本 2
.支持库 spec


.程序集 窗口程序集_窗口1


.子程序 _窗口1_创建完毕






.子程序 发送封包程序
.局部变量 游戏端口, 整数型
.局部变量 封包内容, 字节集
.局部变量 封包指针, 整数型
.局部变量 封包大小, 整数型
.局部变量 i, 整数型


.计次循环首 (到整数 (编辑框2_发送次数.内容), i)
    游戏端口 = 到整数 (编辑框4_游戏端口.内容)


    封包内容 = 转换_字节集还原 (删全部空 (编辑框1_发送封包.内容), )


    封包指针 = 指针_取字节集地址 (封包内容)


    封包大小 = 取字节集长度 (封包内容)


    延迟 (到整数 (编辑框3_发送间隔.内容))


    编辑框5_己发次数.内容 = 到文本 (i)


    封包拦截.发送send (游戏端口, 封包指针, 封包大小, 0)


.计次循环尾 ()




.子程序 _按钮1_被单击


发送封包程序 ()

32

主题

434

帖子

204

学币

高级会员

Rank: 4Rank: 4Rank: 4Rank: 4

积分
2169

最佳新人活跃会员

发表于 2017-12-20 08:00:42 | 显示全部楼层
前来学习
回复

使用道具 举报

0

主题

9

帖子

37

学币

初级会员

Rank: 2Rank: 2

积分
101
发表于 2018-4-24 10:54:44 | 显示全部楼层
来顶你了
回复

使用道具 举报

237

主题

380

帖子

1108

学币

钻石会员

Rank: 6

积分
3276
发表于 2018-5-4 09:16:06 | 显示全部楼层
谢谢分享,辛苦了。

0

主题

1660

帖子

117

学币

初级会员

Rank: 2Rank: 2

积分
187
发表于 2018-6-4 21:39:44 | 显示全部楼层
挨骂也是幸福~~~

0

主题

1660

帖子

117

学币

初级会员

Rank: 2Rank: 2

积分
187
发表于 2018-6-7 23:16:04 | 显示全部楼层
手游挂第三课

0

主题

79

帖子

172

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
316
发表于 2018-7-1 09:56:49 | 显示全部楼层
学习
回复

使用道具 举报

4

主题

33

帖子

122

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
340
发表于 2018-7-5 18:48:43 | 显示全部楼层
128进制转换工具可以发个连接么

5

主题

100

帖子

428

学币

高级会员

Rank: 4Rank: 4Rank: 4Rank: 4

积分
1046

最佳新人活跃会员宣传达人热心会员赞助会员

发表于 2018-7-9 20:56:05 | 显示全部楼层
fffff
回复

使用道具 举报

6

主题

61

帖子

193

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
328
发表于 2018-7-27 15:57:46 | 显示全部楼层
支持支持,谢谢老师
展开

QQ|小黑屋|手机版|虫虫教学 ( 赣ICP备18011882号 )

GMT+8, 2020-6-4 06:38 , Processed in 0.069073 second(s), 53 queries .

bestcclm. com X3.4

© 2018 Bestcclm.

快速回复 返回顶部 返回列表