虫虫教学

 找回密码
 立即注册

QQ登录

广告位招租
binge
查看: 20285|回复: 183

手游封包外挂第四课:封包发送器 DLL钩子程序的编写

  [复制链接]
发表于 2017-10-8 10:51:00 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
手游封包外挂第四课:封包发送器 DLL钩子程序的编写


回帖子可观看:


游客,如果您要查看本帖隐藏内容请回复



                这课要用到的易语言模块是:魔鬼作坊VIP模块V8.0
请同学们课前先下截好模快,然后安装到易语言上,再跟到本课程进行操作!


魔鬼作坊VIP模块V8.0   下载地址    https://pan.baidu.com/s/1lU9ccb9O5iJIR9Ava2RV2w



发表于 2019-8-28 13:24:11 | 显示全部楼层
程序集1源码

.版本 2
.程序集 程序集1
.子程序 _启动子程序, 整数型, , 请在本子程序中放置动态链接库初始化代码

返回 (0)  ' 返回值被忽略。
.子程序 钩子DLL接口, 整数型, 公开
.参数 一, 整数型
.参数 二, 整数型
.参数 三, 整数型

返回 (注入_钩子dll初始化 (一, 二, 三, &初始, &退出, ))


.子程序 初始
载入 (窗口1, , 真)

.子程序 退出
结束 ()

窗口程序集源码


.版本 2
.程序集 窗口程序集_窗口1
.子程序 _窗口1_创建完毕


.子程序 _按钮1_被单击
.局部变量 游戏端口, 整数型
.局部变量 封包内容, 字节集
.局部变量 封包指针, 整数型
.局部变量 封包大小, 整数型

游戏端口 = 到整数 (编辑框4_游戏端口.内容)
封包内容 = 转换_字节集还原 (删全部空 (编辑框1_发送封包.内容))
封包指针 = 指针_取字节集地址 (封包内容)
封包大小 = 取字节集长度 (封包内容)
封包拦截.发送send (游戏端口, 封包指针, 封包大小, 0)


0

主题

5

帖子

37

学币

初级会员

Rank: 2Rank: 2

积分
80

最佳新人

发表于 2017-10-9 07:33:27 | 显示全部楼层
这个只能针对一个游戏吗?

71

主题

110

帖子

1249

学币

高级会员

Rank: 4Rank: 4Rank: 4Rank: 4

积分
1906

最佳新人答题高手发贴达人推广达人

发表于 2017-10-25 22:22:50 | 显示全部楼层
虫虫嗨嗨嗨 发表于 2017-10-9 07:33
这个只能针对一个游戏吗?

其他游戏都可以的 但是需要 你自己修改源码  针对你要玩的游戏

14

主题

207

帖子

288

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
934

热心会员最佳新人最帅男会员活跃会员幸运星幸运草发贴达人虫虫萌宠最美女会员

发表于 2017-12-11 17:54:53 | 显示全部楼层

学习了哦!
回复

使用道具 举报

0

主题

3

帖子

28

学币

初级会员

Rank: 2Rank: 2

积分
80

最佳新人

发表于 2018-1-7 13:59:54 | 显示全部楼层
网游可以吗,比如荒野行动

1

主题

77

帖子

244

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
622

最佳新人活跃会员

发表于 2018-1-27 07:16:31 | 显示全部楼层
老师辛苦啦!

0

主题

16

帖子

24

学币

初级会员

Rank: 2Rank: 2

积分
265
发表于 2018-2-5 00:31:15 来自手机 | 显示全部楼层
老师,这些工具想在手机上运行应该用类似什么来编写。

78

主题

635

帖子

1360

学币

VIP会员

Rank: 9Rank: 9Rank: 9Rank: 9

积分
3859

最佳新人活跃会员推广达人热心会员宣传达人赞助会员

发表于 2018-2-20 09:55:40 来自手机 | 显示全部楼层
感谢分享
回复

使用道具 举报

8

主题

30

帖子

124

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
699

最佳新人活跃会员宣传达人热心会员荣誉会员

发表于 2018-3-6 21:15:10 | 显示全部楼层
值得学习

5

主题

67

帖子

113

学币

初级会员

Rank: 2Rank: 2

积分
458
发表于 2018-3-22 16:13:58 | 显示全部楼层
感谢分享
回复

使用道具 举报

展开

QQ|小黑屋|手机版|虫虫教学 ( 赣ICP备18011882号 )

GMT+8, 2021-3-9 05:47 , Processed in 0.076005 second(s), 59 queries .

bestcclm. com X3.4

© 2018 Bestcclm.

快速回复 返回顶部 返回列表