虫虫教学

 找回密码
 立即注册

QQ登录

查看: 2512|回复: 107

手游封包外挂第十一课:同时拦截多个封包的编程

  [复制链接]
发表于 2017-11-5 17:10:04 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
手游封包外挂第十一课:同时拦截多个封包的编程

                                 教程地址:回复帖子才可观看


         
游客,如果您要查看本帖隐藏内容请回复







 楼主| 发表于 2019-8-25 19:38:26 | 显示全部楼层
.本课源码


.版本 2


.局部变量 a, 文本型
.局部变量 返回值, 整数型
.局部变量 a1, 文本型
.局部变量 返回值1, 整数型




.如果真 (封包长度 > 到整数 (编辑框2.内容) 且 封包长度 < 到整数 (编辑框3.内容))


    .如果真 (选择框1.选中 = 真)
        a = 转换_字节集到十六进制 (指针到字节集 (封包指针, 封包长度))
        返回值 = 寻找文本 (a, 编辑框4_特征码.内容, , 假)


        .如果真 (返回值 ≠ -1)
            ' 编辑框1.加入文本 (“端口:” + 到文本 (套节字) + “封包大小:” + 到文本 (封包长度) + “封包内容:” + 转换_字节集到十六进制 (指针到字节集 (封包指针, 封包长度)) + #换行符)
            .如果真 (选择框2.选中 = 真)
                编辑框1.加入文本 (“阻止封包\” + 编辑框4_特征码.内容 + “封包发服务器内容:” + 转换_字节集到十六进制 (指针到字节集 (封包指针, 封包长度)) + #换行符)
                返回 (-1)


            .如果真结束


        .如果真结束


        ' -------------------------------------------------------------------


        a1 = 转换_字节集到十六进制 (指针到字节集 (封包指针, 封包长度))
        返回值1 = 寻找文本 (a1, 编辑框4_特征码2.内容, , 假)


        .如果真 (返回值1 ≠ -1)
            ' 编辑框1.加入文本 (“端口:” + 到文本 (套节字) + “封包大小:” + 到文本 (封包长度) + “封包内容:” + 转换_字节集到十六进制 (指针到字节集 (封包指针, 封包长度)) + #换行符)
            .如果真 (选择框2.选中 = 真)
                编辑框1.加入文本 (“阻止封包\” + 编辑框4_特征码2.内容 + “封包发服务器内容:” + 转换_字节集到十六进制 (指针到字节集 (封包指针, 封包长度)) + #换行符)
                返回 (-1)


            .如果真结束


        .如果真结束


    .如果真结束






.如果真结束
返回 (0)


211

主题

352

帖子

1034

学币

高级会员

Rank: 4Rank: 4Rank: 4Rank: 4

积分
2839
发表于 2018-5-4 09:15:31 | 显示全部楼层
谢谢分享,辛苦了。

0

主题

1660

帖子

113

学币

初级会员

Rank: 2Rank: 2

积分
183
发表于 2018-6-4 21:40:42 | 显示全部楼层
支持楼主,支持原创!

0

主题

1660

帖子

113

学币

初级会员

Rank: 2Rank: 2

积分
183
发表于 2018-6-7 23:16:58 | 显示全部楼层
手游辅助第十一课  

1

主题

149

帖子

20

学币

高级会员

Rank: 4Rank: 4Rank: 4Rank: 4

积分
1073

最佳新人

QQ
发表于 2018-7-13 16:22:00 | 显示全部楼层
学习咯
回复

使用道具 举报

3

主题

57

帖子

7

学币

新手上路

Rank: 1

积分
82
发表于 2018-8-10 08:54:18 来自手机 | 显示全部楼层
能分享他人痛苦的,是人;能分享他人快乐的,是神。                                                    ——歌德 引用曾经好友的签名:         百般努力,只为出人头地!  今日多学一门技术,明日少说一句求人话!  

12

主题

287

帖子

611

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
878
发表于 2018-10-22 21:20:40 来自手机 | 显示全部楼层
非常感谢,感谢分享!

4

主题

219

帖子

72

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
872
发表于 2019-8-26 08:35:10 | 显示全部楼层
好的,辛苦了

0

主题

21

帖子

37

学币

初级会员

Rank: 2Rank: 2

积分
319
发表于 2019-9-20 23:48:29 来自手机 | 显示全部楼层
我也说一句前来学习
展开

QQ|小黑屋|手机版|虫虫教学 ( 赣ICP备18011882号 )

GMT+8, 2020-2-29 07:37 , Processed in 0.162909 second(s), 52 queries .

bestcclm. com X3.4

© 2018 Bestcclm.

快速回复 返回顶部 返回列表