虫虫教学

 找回密码
 立即注册

QQ登录

查看: 2359|回复: 9

手游封包外挂第九课:特征码拦截 (2019最新版)

[复制链接]
发表于 2017-10-8 11:04:02 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
手游封包外挂第九课:特征码拦截



视频地址   百度网盘: https://pan.baidu.com/s/10wy9SS0iz8KppfmnFS1EBg


           本课用到的工具:封包对比工具 下载地址 https://pan.baidu.com/s/1jbzwELvfNbd4BMdeuEGjEA




   

发表于 2019-8-24 01:10:10 | 显示全部楼层

第九课源码

.版本 2
.支持库 spec


.程序集 窗口程序集_窗口1


.子程序 _窗口1_创建完毕
.子程序 发送封包程序
.局部变量 游戏端口, 整数型
.局部变量 封包内容, 字节集
.局部变量 封包指针, 整数型
.局部变量 封包大小, 整数型
.局部变量 i, 整数型

.计次循环首 (到整数 (编辑框2_发送次数.内容), i)
    游戏端口 = 到整数 (编辑框4_游戏端口.内容)
    封包内容 = 转换_字节集还原 (删全部空 (编辑框1_发送封包.内容), )
    封包指针 = 指针_取字节集地址 (封包内容)
    封包大小 = 取字节集长度 (封包内容)
    延迟 (到整数 (编辑框3_发送间隔.内容))
    编辑框5_己发次数.内容 = 到文本 (i)
    封包拦截.发送send (游戏端口, 封包指针, 封包大小, 0)
.计次循环尾 ()
.子程序 _按钮1_被单击
发送封包程序 ()
.子程序 _按钮2_被单击
封包拦截.安装send (&拦截send)
.子程序 拦截send, 整数型
.参数 套节字, 整数型
.参数 封包指针, 整数型
.参数 封包长度, 整数型
.局部变量 a, 文本型
.局部变量 返回值, 整数型

.如果真 (封包长度 > 到整数 (编辑框2.内容) 且 封包长度 < 到整数 (编辑框3.内容))
   .如果真 (选择框1.选中 = 真)
        a = 转换_字节集到十六进制 (指针到字节集 (封包指针, 封包长度))
        返回值 = 寻找文本 (a, 编辑框4_特征码.内容, , 假)
     .如果真 (返回值 ≠ -1)
            编辑框1.加入文本 (“端口:” + 到文本 (套节字) + “封包大小:” + 到文本 (封包长度) + “封包内容:” + 转换_字节集到十六进制 (指针到字节集 (封包指针, 封包长度)) + #换行符)
       .如果真结束

   .如果真结束

.如果真结束
返回 (0)

.子程序 _按钮3_被单击
  封包拦截.卸载send ()


205

主题

343

帖子

1025

学币

高级会员

Rank: 4Rank: 4Rank: 4Rank: 4

积分
2709
发表于 2018-5-4 09:15:44 | 显示全部楼层
谢谢分享,辛苦了。

0

主题

1660

帖子

113

学币

初级会员

Rank: 2Rank: 2

积分
183
发表于 2018-6-4 21:40:20 | 显示全部楼层
我帮不了你

0

主题

1660

帖子

113

学币

初级会员

Rank: 2Rank: 2

积分
183
发表于 2018-6-7 23:16:34 | 显示全部楼层
百度网盘:http://pan.baidu.com/s/1pKTlNg3

6

主题

61

帖子

193

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
328
发表于 2018-7-27 15:58:20 | 显示全部楼层
支持支持,谢谢老师

12

主题

287

帖子

611

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
878
发表于 2018-10-22 21:20:27 来自手机 | 显示全部楼层
非常感谢,感谢分享!

61

主题

189

帖子

295

学币

高级会员

Rank: 4Rank: 4Rank: 4Rank: 4

积分
1577
发表于 2018-12-19 01:35:58 | 显示全部楼层
非常感谢,感谢分享!

1

主题

6

帖子

0

学币

新手上路

Rank: 1

积分
31
发表于 2019-3-5 03:22:32 | 显示全部楼层
如果是发包呢不是接受易语言怎么写啊?

点评

后面会讲到的,亲  发表于 2019-8-24 01:07
展开

QQ|小黑屋|手机版|虫虫教学 ( 赣ICP备18011882号 )

GMT+8, 2019-12-8 06:25 , Processed in 0.155508 second(s), 53 queries .

bestcclm. com X3.4

© 2018 Bestcclm.

快速回复 返回顶部 返回列表