虫虫教学

 找回密码
 立即注册

QQ登录

查看: 3541|回复: 17

手游封包外挂第七课 : 截取游戏发给服务器的封包

[复制链接]
发表于 2017-10-8 10:56:46 | 显示全部楼层 |阅读模式

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
手游封包外挂第七课: 截取游戏发给服务器的封包

          因视频上传审核不过关,所以请同学们到百度网盘下载观看学习!


               视频下载地址: https://pan.baidu.com/s/1RkrDd0P_-zGzYJCLR3QwfA





发表于 2019-8-22 22:21:47 | 显示全部楼层
本课源码:

.版本 2
.支持库 spec

.程序集 窗口程序集_窗口1

.子程序 _窗口1_创建完毕

.子程序 发送封包程序
.局部变量 游戏端口, 整数型
.局部变量 封包内容, 字节集
.局部变量 封包指针, 整数型
.局部变量 封包大小, 整数型
.局部变量 i, 整数型


.计次循环首 (到整数 (编辑框2_发送次数.内容), i)
    游戏端口 = 到整数 (编辑框4_游戏端口.内容)

封包内容 = 转换_字节集还原 (删全部空 (编辑框1_发送封包.内容), )

封包指针 = 指针_取字节集地址 (封包内容)


封包大小 = 取字节集长度 (封包内容)

延迟 (到整数 (编辑框3_发送间隔.内容))

编辑框5_己发次数.内容 = 到文本 (i)

封包拦截.发送send (游戏端口, 封包指针, 封包大小, 0)

.计次循环尾 ()

.子程序 _按钮1_被单击

发送封包程序 ()


~~~~~~~~~~~~~~~~~~~~~~~~~~(以下部分是增加的源码,上面的是第六课源码)

.子程序 _按钮2_被单击

封包拦截.安装send (&拦载封包)

.子程序 拦载封包, 整数型
.参数 套节字, 整数型
.参数 封包指针, 整数型
.参数 封包长度, 整数型

编辑框1.加入文本 (“端口” + 到文本 (套节字) + “封包大小” + 到文本 (封包长度) + “封包内容” + 转换_字节集到十六进制 (指针到字节集 (封包指针, 封包长度)) + #换行符)
返回 (0)

.子程序 _按钮3_被单击

封包拦截.卸载send ()







0

主题

1

帖子

6

学币

新手上路

Rank: 1

积分
30
发表于 2017-12-5 00:32:21 来自手机 | 显示全部楼层
我也说一句没有安卓的么

8

主题

28

帖子

121

学币

VIP会员

Rank: 9Rank: 9Rank: 9Rank: 9

积分
573

最佳新人活跃会员宣传达人热心会员赞助会员

发表于 2018-3-6 21:15:28 | 显示全部楼层
值得学习

0

主题

9

帖子

37

学币

初级会员

Rank: 2Rank: 2

积分
101
发表于 2018-4-24 10:54:54 | 显示全部楼层
来顶你了
回复

使用道具 举报

205

主题

343

帖子

1025

学币

高级会员

Rank: 4Rank: 4Rank: 4Rank: 4

积分
2709
发表于 2018-5-4 09:15:58 | 显示全部楼层
谢谢分享,辛苦了。

4

主题

32

帖子

185

学币

初级会员

Rank: 2Rank: 2

积分
403

最佳新人

发表于 2018-5-12 21:46:33 来自手机 | 显示全部楼层
哈哈
回复

使用道具 举报

0

主题

1660

帖子

113

学币

初级会员

Rank: 2Rank: 2

积分
183
发表于 2018-6-4 21:39:56 | 显示全部楼层
我们为什么要相遇 上帝说是为了还清前世欠下的孽债 然后我笑了.前世我们过了奈何桥.为什么我们那么傻,喝不下那碗孟婆汤

0

主题

1660

帖子

113

学币

初级会员

Rank: 2Rank: 2

积分
183
发表于 2018-6-7 23:16:15 | 显示全部楼层
辛苦了,辛苦了

6

主题

61

帖子

193

学币

中级会员

Rank: 3Rank: 3Rank: 3

积分
328
发表于 2018-7-27 15:57:58 | 显示全部楼层
支持支持,谢谢老师

7

主题

149

帖子

22

学币

初级会员

Rank: 2Rank: 2

积分
425

幸运星发贴达人最美女会员最帅男会员最佳新人幸运草

发表于 2018-8-2 05:04:12 | 显示全部楼层
非常好
回复

使用道具 举报

展开

QQ|小黑屋|手机版|虫虫教学 ( 赣ICP备18011882号 )

GMT+8, 2019-12-7 08:56 , Processed in 0.141242 second(s), 59 queries .

bestcclm. com X3.4

© 2018 Bestcclm.

快速回复 返回顶部 返回列表